Posts Tagged ‘Konfiguration’

Fehlermeldungen Xdebug in apache_error_log unter MAMP Failed loading /usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so

Wednesday, June 30th, 2010

;Problem: Fehlermeldungen
:Error in /Applications/MAMP/logs/apache_error_log: ”’Failed loading /usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so”’

[Tue Jun 29 18:14:41 2010] [error] …
Failed loading /usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so: (null)
Failed loading /usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so: (null)
Failed loading /usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so: (null)

  • Wieder Anleitung von Debuggable benutzt.
  • Von Kommodo Downloads Remote Debugging Komodo-PHPRemoteDebugging-6.0.0-beta1-44391-macosx.tar.gz runtergeladen.
  • in /Applications/MAMP/bin/php5/lib/php/extensions/ gespeichert und entpackt (sollte eigentlich woanders hin - unter downloads o.ä.)
  • Unterordner für alle PHP-Versionen (!) drin: Version 5.1, 5.2, 5.3
  • bei mir installiert ist 5.2 (phpinfo())
  • in php.ini Pfad herausfinden, nach dem MAMP-PHP sucht:
  • in /Applications/MAMP/conf/php5/php.ini:
  • unter Paths and Directories den Eintrag: extension_dir = “/Applications/MAMP/bin/php5/lib/php/extensions/no-debug-non-zts-20050922/ gefunden
  • dort (in in /Applications/MAMP/conf/php5/php.ini) war noch eine Einstellung zend_extension=”/usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so unter den Einstellungen für Xdebug/ZEND - diese muss auskommentiert werden, sie überschreibt sonst den Pfad für das extension_dir: ;zend_extension=”/usr/…”!!
  • xdebug.so aus Unterordner “5.2″ in /Applications/MAMP/bin/php5/lib/php/extensions/no-debug-non-zts-20050922/ kopiert
  • Apache neu gestartet
  • funktioniert: keine Fehlermeldungen mehr

Dank an Christian Hartmann für die Hilfe !!!

Installing PECL for MAMP

Monday, May 3rd, 2010

There are a couple of installation instructions for PECL around. But if you use it together with MAMP, installation still doesn’t work (or install things somewhere near the nirvana). This is about how to install it the right way, tie it to MAMP and make your Terminal use the right one from now on:

Installing PECL in MAMP

http://developerkarma.com/blog/andrew-m-riley/quick-and-dirty-pecl-mamp-os-x shows how to install pecl directly into mamp.

Your PECL should now be available at /Applications/MAMP/bin/php5/bin/pecl

Use MAMP PECL instead of the wrong one

As you might have an additional “system” pecl in your system server path (which is used by default when you just enter “pecl install” or something alike), make sure you use the mamp one in the terminal.

The easiest way is to adress pecl using the full url any time you call it: Instead of typing

pecl install something

type:

/Applications/MAMP/bin/php5/bin/pecl install something

Pointing to the MAMP PECL from your terminal permanently

This is pretty annoying after a while (and error-prone beyond that!) so tell your terminal which one to use. To do this add an alias in your .bashrc file:

edit the .bashrc of your personal account:

propellermac:testcase achimbode$ sudo edit ~/.bashrc

To the ~/.bashrc file add the following line:

alias pecl=/Applications/MAMP/bin/php5/bin/pecl

When you start a new terminal window, your .bashrc should be run automatically and typing

pecl install something

should now point to the right pecl.

Execute .bashrc automatically

If the .bashrc is not run automatically on shell startup, create a bash_profile.

It’s just about editing the file and add a few lines you find on the page mentioned above. If the file does not exist, create it:

propellermac:testcase achimbode$ sudo edit ~/.bash_profile

The following code is copied from http://forums.macrumors.com/showthread.php?t=409238

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

export PS1=’\[\e[0;31m\]\u\[\e[0m\]\[\e[1;31m\]@\[\e[0m\]\[\e[0;31m\]\H\[\e[0m\] \w $ ‘
source ~/.bashrc

It also colors your terminal prompt red, so you know if it works…
This looks like a lot of work. But actually it’s just editing a few files. And it’s worth while: No more confusion when installing libraries to MAMP! Have fun!

Woogle configuration Error: Class ‘WoogleQueryServiceNative’ not found

Friday, March 26th, 2010

Hi everyone,

I had a little problem with the Woogle installation, but was able to solve
it. Just posting to allow for the “debug by googleing” procedure we
all know.

I installed the remote backend and the extension. Search now uses
Woogle, but obviously tries to access the native version:

Fatal error: Class ‘WoogleQueryServiceNative’ not found in /var/www/
15.1/wooglewiki/extensions/Woogle/includes/WoogleUtil.php on line 179

I found the solution in the …/extensions/Woogle/addons/Remote/
Remote.php.

The config settings displayed on http://www.teamweaver.org/wiki/index.php/Woogle4MediaWiki/Configuration
are not complete - the actual setting that makes Woogle switch to
remote mode is missing. The complete version is:

I found the solution in the …/extensions/Woogle/addons/Remote/Remote.php:

The config settings displayed on http://www.teamweaver.org/wiki/index.php/Woogle4MediaWiki/Configuration are not complete - the actual setting that makes Woogle switch to remote mode is missing. The complete version is:

LocalSettings.php:

require_once(”$IP/extensions/Woogle/Woogle.php”);

// Woogle Configuration

WoogleConfig::set(’indexAddon’, ‘Remote’); // set the respective backend URL here

WoogleConfig::set(’remoteBaseServiceUrl’, ‘http://octopus13.fzi.de:9999/teamweaverIS-backend/services/’); // set the respective backend URL here
WoogleConfig::set(’remoteAuthKey’, ’secret’); // key for querying, only required if the backend is set to securityEnabled = true;
WoogleConfig::set(’indexGroups’, array(’group1′, ‘group2′));
WoogleConfig::set(’indexRepository’, ‘123′); // numeric id for indexing (repoId) - as configured in the backend repo_config.xml
WoogleConfig::set(’remotePushIndexAuthKey’, ’secret2′); // key for indexing - as configured in the backend repo_config.xml

Great app, though. This is what we all have been waiting for, so make sure to keep going!
Achim

I posted this to the Woogle Mailinglist, but it was said to be postponed for supervision by the admins. As far as I know the initiator of the project is on holiday for a couple of weeks (at least I read his Email Responder that way…), so I cross posted it here.

Konfiguration: MediaWiki bei HostEurope einrichten

Monday, March 8th, 2010

Ich habe manuell ein Mediawiki eingerichtet und die Email-Authentifikation funktioniert nicht - was muss ich in die LocalSettings.php eintragen, damit Mediawiki den Mailserver findet?

Für alle, die sich die gleiche Frage stellen, hier die Lösung:

$wgSMTP = array(
‘host’ => “localhost”, // oder IP-Addresse
‘IDHost’ => “achimbo.de”, // eigene Domain eintragen
‘port’ => 25,
‘auth’ => true,
‘username’ => “wp1020014-jo”, // In KIS unter “Administration > Webhosting > 1020014 > E-Mail > E-Mail-Konten verwalten” bzw. “Administration > Webhosting > 1020014 > E-Mail > E-Mail-Konten verwalten / Autoresponder / Filter / Webmailer”
‘password’ => “my_password” // ebenfalls dort eingetragen
);

Und zu guter Letzt:
–> Damit man via Script E-Mails verschicken kann, muss im KIS eine Standard E-Mail Adresse hinterlegt sein. Die konfiguriert man in KIS unter “Administration > Webhosting > Konfigurieren > Skripte > Standard-E-Mail-Adresse”. Dort die E-Mail Adresse hinterlegen mit der das Script die E-Mails verschickt.

Viel Spaß!

Problem mit Skype Messages - lassen sich nicht abschalten

Monday, November 9th, 2009

Problem Skype Messages

Problem: Seit dem Neustart zeigt Skype jedesmal ein Fenster, wenn ein Kontakt online oder offline geht…

  1. erste Recherche
  2. rausgefunden: Problem besteht, seit Growl installiert ist
  3. Skype-Nachrichten in Growl abschalten

erste Recherche

Help for Skype – user guides, FAQs, customer support

https://support.skype.com/search/?q=switch+off+messages+when+contact+available

Can the user disable the messages in Skype?

There is an option to disable these messages under Tool > Options > Notifications. You can choose to turn off some or all

Eine Einstellung für Nachrichten gibt es nicht. Mögliche Einstellungen sind:

Event = contact becomes available, options = play sound, bounce icon, speak text

Growl und Skype

Habe rekonstruiert, dass das Problem erst auftrat, seit ich Growl installiert habe. Die Fenster kamen mir gleich so bekannt vor… Growl brauche ich zur Darstellung der Ubiquity-Nachrichten.

Enabling Skype with Growl (GrowlSkype documentation)

As of Skype 2.7, you no longer have to do anything. Growl should Just Work.
Skype before 2.7

In general Skype should not need any configuration to work with Growl. In older versions, you may need to check a box in Skype’s advanced preferences, and that should be it.

Should you need to enable Growl in Skype, you would do this in the Skype advanced preferences. It is the bottom checkbox, as shown in this screen shot…

Offenbar hatten andere das Problem mit Skype-Nachrichten in Growl auch schon:

cocoaforge • View topic - Growl and Skype - Messages when in focus

Growl and Skype - Messages when in focus

Postby drysdan » Sun Nov 01, 2009 1:26 am
I’m using OSX 10.6, Skype 2.8, and Growl 1.2.

Growl and Skype seem to be working great, but I can’t find a way to make it NOT notify me of incoming chat messages when I’m already focused on the Skype chat window. I want it to notify me of new messages when I’m focused on another application, but when I’m already in the chat window, it’s pretty annoying. Any ideas?

Thanks!!
-T

Bisher keine Antwort… - Antworten ist in diesem Cocoa-Forum leider nicht möglich — warum eigentlich nicht?

Ich benutzte ebenfalls OSX 10.6, Skype 2.8, and Growl 1.2.

Skype-Nachrichten in Growl abschalten

Wenn man rausgefunden hat, wer hier eigentlich spricht, kann man, kann man das Übel an der Wurzel packen: durch Konfiguration von Growl:

Einstellungen Growl in den Systemeinstellungen

Auch wenn Growl dämonisch im Hintergrund lauert, kann man es komfortabel in einem Einstellungsfenster konfigurieren…

Firefox: RSS-Feed wieder selbst angucken

Monday, January 12th, 2009

Problem:

wie kann ich den RSS-Feed wieder selbst angucken, wenn ich ihn manuell weiter verarbeiten will? Im Moment wird das von Firefox automatisch an RSS-Reader-AddOn Brief weitergeleitet… (dynamisches Lesezeichen hinzufügen)

Suche: dynamisches Lesezeichen hinzufügen rss anzeigen

http://www.firefox-browser.de/forum/viewtopic.php?t=35711&highlight=rss

about:config

Filter: bookmarks

about:config
browser.feeds.handler Wert: bookmarks

Was gibt es für andere Werte (values)?
Suche: List Werte Liste dynami “browser.feeds.handler” (value OR Wert)

http://sisyphus.ru/srpm/Sisyphus/firefox-settings-desktop/sources/0

Lösung:

about:config
browser.feeds.handler Wert: bookmarks
Wert auf “ask” setzen

funktioniert!

Damit bekommt man wieder die vertraute, von Firefox gerenderte Version.
Wer sich dann den (RSS-) XML-Code anzeigen lassen möchte, wählt im Menü Anzeige > Quellcode (bzw. View > source code)

Thanks to: firefox-browser.de/forum und sisyphus.ru!